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Exam : LOTUS 190-951

Title : IBM Lotus Notes Domino 8.5 Application Development Update

1. Farah has added the main.css stylesheet to her XPage. She wants to associate the helpText class from main.css 

with the lblHelp Label control on the page. How can Farah do this task?

A.Select the Source tab from the Xpage canvas and enter this line:

B.Right-click lblHelp from the XPage. On the HTML tab of the Properties window, enter helpText for the Class option.

C.Select the lblHelp control on the Xpage. From the Style tab of the Properties window, enter helpText for the Class 

option.

D.Select the Source tab from the Xpage canvas. Locate the line. Below this line, add:

Answer: C

2. Viktor has been asked to begin modifying the corporate Domino Web sites to adhere to XHTML standards. He has 
enabled Enable enhanced HTML generation in the application properties. When testing a couple of the page elements 

in the Web browser and viewing the source, Viktor notices that tags like

and are still not correctly closed, that is.,

. What could be the problem?

A.This setting only applies to generated HTML, like passthrough HTML on a form.

B.The Web closes tags that have content. Tags that do not have content are ignored.

C.Each page element needs to be opened and saved to incorporate this new application property setting.

D.The Web server generates valid XML, but there are exceptions. One of the exceptions is passthrough HTML.

Answer: D

3. Lainey has recently upgraded to Notes Domino 8.5. She is now exploring the design of her applications to see what 

new features might be available. What is the purpose of the controls palette that Lainey sees?

A.The controls palette contains controls, such as Edit Box, File Upload, and Table that the developer can drag onto 

the XPage canvas.

B.The controls palette is another way to access the same items that are available from the Create menu for forms, 

views, XPages and other design elements.

C.The controls palette contains items like Edit Box, Button, and Label that the developer can drag onto XPages and 

forms. The controls palette is not available for views and pages.

D.The controls palette contains UI and other controls (such as Button, Link, and Image) that allow the developer to 

drag controls onto XPage or page elements. The controls palette is not available for other elements.

Answer: A

4. Kaitlyn has been asked to track which browser versions people are using to access the Customers XPage. She 

wants to add code that writes the browser version to the server log whenever a user opens the XPage.
What server-side code can Kaitlyn add to do this task? 

A.Add this code in the beforePageLoad event of the XPage:
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A.Add this code in the beforePageLoad event of the XPage:
var req = facesContext.getExternalContext().getRequest();print(req.getHeader("User-Agent")); 

B.Add this code in the onLoad event of the XPage:

var req = facesContext.getExternalContext().getRequest();print(req.get(HTTP_USER_AGENT));

C.Add this code in the onLoad event of the XPage:

print(headerValues.getHeader(HTTP_USER_AGENT));

D.Add this code in the beforePageLoad event of the XPage:
print(headerValues.getHeader("User-Agent")); 

Answer: A

5. Brett wants to add a view to his XPage, configured so that it displays two rows for each entry in the view. What 

technique can he use to accomplish this task?

A.Add a View control to the XPage and configure the view's NumberOfRows property to '2'.

B.Add a View control to the XPage and change the NumberOfRows property on the All Properties tab to '2'.

C.Enable the Application property Use Java Views on Web and configure the view's NumberOfRows property to '2'.

D.Add a Repeat control to the XPage and place the appropriate fields within the Repeat control in a two row table.

Answer: D

6. The DiscussionTopics XPage includes a button to take users to the Feedback XPage. Ted has created the 

Feedback XPage. He now wants to add a Save and close button that saves the user's input, and take the user back 

to the DiscussionTopics XPage. What is one way he can do this task?

A.Drag a new Button control onto the XPage canvas. Set the button type to Submit. For the onclick event, add the 
following server-side JavaScript:Feedback.save(); 

B.Drag a new Button control onto the XPage canvas. Set the button type to Submit. For the onclick event, add the 
following server-side JavaScript:Feedback.save();context.getUrl(".."); 

C.Drag a new Button control onto the XPage canvas. Leave the button type as Button. For the onclick event, add a 

simple action, selecting Save Document. Specify DiscussionTopics as the argument.

D.Drag a new Button control onto the XPage canvas. Leave the button type as Button. For the onclick event, add a 

simple action, selecting Save Data Sources. Specify DiscussionTopics as the argument.

Answer: D

7. Qiang needs to add a button to the Contact XPage. When clicked, this button should delete the currently-open 

document from the application. What is one way that Qiang can add this button?

A.Drag the Data control from the core controls onto the XPage canvas. From the Control properties, set the Label to 

Delete. On the Operations tab, select Current document and Delete.

B.Drag the Data control from the core controls onto the XPage canvas. From the Control properties, set the Label to 

Delete. In the Options area of the properties, select Delete for the Action, and select Domino Document for the Target.

C.Drag a Button control from the core controls onto the XPage canvas. From the Control properties, set the Label to 
Delete. On the events panel, select the Mouse onclick event, and add a server-side simple action. Select Delete for 

the action.

D.Drag a Button control from the core controls onto the XPage canvas. From the Control properties, set the Label to 
Delete. On the events panel, select the Mouse onclick event, and add a client-side simple action. Select Delete for 

the action.

Answer: C

8. Pablo has created an XPage to use for browsing and editing customer data. He would like to add a button which 

asks users if they are sure that they want to update the customer data. The button saves the changes if users 

indicate that they are sure.

How can Pablo create this button?

A.Drag a button control from the core controls onto the XPage canvas. From the Control properties, select Save as 

the button type, and enable the Confirm option.

B.Drag a button control from the core controls onto the XPage canvas. From the Control properties, select Save as 

the button type. A confirmation prompt is included by default.

C.Drag a button control from the core controls onto the XPage canvas. From the Control properties, select Submit as 
    

 
    

 

 
 

 

 

 
   

 

 

 
   

 

 

 

 
   

 
   

 

 

 
 

 

 

 

 

 

 
   

 
   

 
   

 
   

 

 

 

 

 
   

    

 
    

   

    

   

    

 

 

 

 

 

 

 

 

 
    

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
   

 

 
 

 

 

 

   

    

 

 
    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

   

 

                                

                                

                



    

       

          

 

       

   

     

     

  

  

     

 

   
   

   

 

  

 

   

   
        

 

       

    

     

 

     

 
 

   

 

   
   

 

 

   

        

 

   
   

 

      

    

 

       

       

 

 

  

 

 

  

  

     

   

 

 

 

   

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
    

 
    

 

 

 

 

 
    

 

 

 

 

 

 

 

 

 

 

 

 
    

 
    

 

 

 

 

 

   

 

 

 

 

 

 
   

 

 
   

 

 

 

 

 

 

 

 

 

 

 
the button type. From the events panel, add a server-side simple action. Select Confirm Action for the action. 

D.Drag a button control from the core controls onto the XPage canvas. From the Control properties, select Submit as 
the button type. From the events panel, add a client-side simple action. Select Confirm Action for the action. 

Answer: C

9. Ida has developed the needed functionality in the Customers XPage of her application. The Web design team has 
provided her with the internal.css stylesheet. After Ida imports the stylesheet to her application, how can she add the 

stylesheet to the XPage?

A.Open the XPage in Domino Designer. On the Style tab of the Properties view, click Add style sheet to page and 

select internal.css.
B.Open the XPage in Domino Designer. Right-click in an open area of the XPage and open the Properties window. 

Select internal.css for the Style Sheet option.

C.From the Applications view, select Resources > Style Sheets > internal.css. From the Wiring tab of the Properties 

view, click Add and select XPage > Customers.
D.From the Applications view, double-click to open the internal.css stylesheet. From the Associations tab of the 

Properties view, click Add association and select XPage > Customers.

Answer: A

10. Neil has built an XPage and needs to have a field value to be calculated when the user selects something from a 

Combo box control. How can he do this task?
A.Add server-side JavaScript to the Combo box's onclick event and use the @Function Script Library to execute the 

@SetField function.
B.Add client-side JavaScript to the Combo box's onclick event and use the @Function Script Library to execute the 

@SetField function.

C.Using the Combo box's onchange event, add a simple action of the Modify Field type and define the target field and 

the calculation to determine its value.
D.Using the Combo box's onchange event, add a simple action of the Update Field type and define the target field and 

the calculation to determine its value.

Answer: C

11. Devin has been developing an application that includes an XPage. When he opened the application in Designer 

this morning, he noticed a small "x" icon by the XPages listing in the Applications view. He had closed several of the 

Eclipse views yesterday, and does not see any errors displayed in the remaining views. How can Devin locate the 

problems in the source code?
A.Right-click the "x" icon from the Applications view and select Go To Error. The Problems view displays with the 

cursor at the first error.
B.Display the Problems view by selecting Window > Show Eclipse Views > Problems. Right-click a displayed error 

and select Go To. The Source view opens to the line with the error.
C.Click to expand the XPages listing. A small "x" icon displays by the XPage with the errors. Double-click the name 

of the XPage and the Source view opens to the line with the error.
D.Click to expand the XPages listing. A small "x" icon displays by the XPage with the errors. Double-click the name 

of the XPage. The Source tab opens with the cursor at the first error line.

Answer: B

12. Abbas has imported the screen.css stylesheet into his application. He has discovered that he needs to edit the 

properties of some of the classes in the CSS. What steps can he follow to make the needed changes and save the 

CSS changes within the application?
A.From the application navigator in Designer, expand Resources and expand Style Sheets. Double-click screen.css 

to use the built-in CSS editor. 

B.From the application navigator in Designer, expand Resources and expand Style Sheets. Click screen.css and in 
the Outline view select a class to use the built-in CSS editor. 

C.From the application navigator in Designer, expand Resources and double-click Style Sheets. Select screen.css in 

the Design pane. From the Design tab of the Properties view, double-click a CSS class to edit its properties. 

   

    

 

 

 

 

 

 

 

 

 
    

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
   

 

 
 

 

 

 

   

    

 

 
    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

   

 

                                

                                

                



    

       

          

 

       

   

     

     

  

  

     

 

   
   

   

 

  

 

   

   
        

 

       

    

     

 

     

 
 

   

 

   
   

 

 

   

        

 

   
   

 

      

    

 

       

       

 

 

  

 

 

  

  

     

   

 

 

 

   

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
    

 
    

 

 

 

 

 
    

 

 

 

 

 

 

 

 

 

 

 

 
    

 
    

 

 

 

 

 

   

 

 

 

 

 

 
   

 

 
   

 

 

 

 

 

 

 

 

 

 

 
    

 
    

 

 
 

 

 

 
   

 

 

 
   

 

 

 

 
   

 
   

 

 

 
 

 

 

 

 

 

 
   

 
   

 
   

 
   

 

 

 

 

 
   

    

 
    

   

    

D.From the application navigator in Designer, expand Resources and double-click Style Sheets. Select screen.css in 

the Design pane. From the Web Properties tab of the Properties view, double-click a CSS class to edit its properties. 

Answer: A

13. Odette is designing the index XPage that is used for navigation for her Domino application. For what purpose 

might Odette use the Outline view in Domino Designer in Eclipse while working with the index XPage?

A.To drag elements to rearrange sections and change the sequence of elements on the XPage.

B.To drag controls from the controls palette onto a hierarchical representation of the XML source code, typically 

during the initial design of the XPage.

C.Aside from the expand and collapse icons, nothing in an Outline view is clickable. Nonetheless, the Outline view 

provides an extremely useful means to browse the XML elements of an XPage.

D.The Outline view provides a hierarchical representation of the XML source code in XPages. The developer can 
quickly update various settings from within the Outline view using right-click menu options for each element. 

Answer: A

14. Jack needs to display the release version of the Sales application on the top of each XPage of the site. He has 
created a computed field at the top of the 'home' XPage, and is using this field to set the release version. Jack also 

needs to create a computed field that is placed at the top of each linked Xpage.

What code should he provide for Computed Field of each linked page to display the release version?

A.environment("relVersion");

B.applicationScope("relVersion");

C.var strVersion = "Release: ";strVersion += environment.get("relVersion");strVersion

D.var strVersion = "Release: ";strVersion += applicationScope.get("relVersion");strVersion

Answer: D

15. Martha has a Submit button on her Timesheet XPage. When clicked, the button uses the Save Document simple 

action to save the data to the underlying document. What parameters does Martha have to provide to the Save 

Document simple action?

A.none

B.pageName, mergeConflicts

C.forceSave, createResponse

D.documentName, saveImmediate

Answer: A

16. Nadine has discovered that XPages dynamically generates names of UI elements. She therefore cannot know 

ahead of time what an element's name is when it is passed to the nWeb browser. What function can Nadine use in 
her server-side JavaScript to fetch the generated element ID at runtime? 

A.getClientId

B.getXpageElementId

C.toString(elementId())

D.toString(getElementId())

Answer: A

17. Barb is the lead developer for the Sales application and the Travel application. Each application consists of 

multiple databases. Within the application navigator, Barb would like to be able to list the databases of the Sales 

application together, and then, separate from the Sales application, to list the databases of the Travel application 

together. How can she do this?

A.For each application, create a subfolder under the Data folder. Move each set of databases to the appropriate 

subfolder. Drag each folder onto the application navigator.

B.Click the folders icon within the application navigator. Select the option to Create a new Working Set. Name the 

Working Set "Sales" and select the databases that comprise the Sales application. Perform a similar procedure for 

the Travel application.

C.From Domino Designer select Create > Working Set. Specify "Sales" for the name. From the application properties 
   

 

 
 

 

 

 

   

    

 

 
    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

   

 

                                

                                

                



    

       

          

 

       

   

     

     

  

  

     

 

   
   

   

 

  

 

   

   
        

 

       

    

     

 

     

 
 

   

 

   
   

 

 

   

        

 

   
   

 

      

    

 

       

       

 

 

  

 

 

  

  

     

   

 

 

 

   

 

 

 

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
    

 
    

 

 

 

 

 
    

 

 

 

 

 

 

 

 

 

 

 

 
    

 
    

 

 

 

 

 

   

 

 

 

 

 

 
   

 

 
   

 

 

 

 

 

 

 

 

 

 

 
    

 
    

 

 
 

 

 

 
   

 

 

 
   

 

 

 

 
   

 
   

 

 

 
 

 

 

 

 

 

 
   

 
   

 
   

 
   

 

 

 

 

 
   

    

 
    

   

    

   

    

 

 

 

 

 

 

 

 

 
    

 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
    

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
of each database of the Sales application, select "Sales" from the Working Set drop-down list. Perform a similar 

procedure for the Travel application.

D.Edit the application properties of each database that comprises the Sales application. On the Design tab, specify 
"Sales" for the Working Set option. Repeat for each database of the Sales application. Perform a similar procedure for 

the Travel application.

Answer: B

18. Eamonn has developed and supported several Domino Web applications over the years. He has been told that one 

of the benefits of XPages is that XPages are AJAX-enabled. What is a benefit that Eamonn might expect to see if he 

incorporates AJAX-enabled XPages in his applications? 

A.Faster development using Shared Widgets resources

B.Faster response time due to partial page refreshes
C.Faster response time because JavaScript is now all server-side 

D.Faster development because XML is now automatically converted to JSON

Answer: B

19. Alegria has saved her rental XPage, but there's an error in the XML source code. She knows this because the 

application navigator shows an icon of a red X next to the XPage. Where can she find details about the error?

A.Editor

B.Events view

C.Problems view

D.Application navigator

Answer: C

20. Cade is building an XPage for the Sales application. What are the options from which he can select when defining 

a data source from the data palette?

A.@DbLookup and @DbColumn

B.Domino view and Domino document

C.Data connections and DB2 access views

D.Data connections, DB2 access views, and file resources

Answer: B
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