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Exam : LOTUS 190-838

Title : IBM Lotus Notes Domino 8 Developing Composite Applications

1. While exploring the Composite Applications area within Domino Designer, Henry has noticed several items 

pertaining to WSDL. What is the purpose of a WSDL file in a composite application?

A.A WSDL file contains the DXL representation of the Domino code that will be executed by the components of the 

composite application.

B.A WSDL file reflects the namespaces, properties, actions, and types used for interaction between components of 

the composite application.

C.A WSDL file is only present if the composite application provides one or more Web services, in which case there is 

a WSDL file for each Web service.

D.A WSDL file is only present if the composite application consumes one or more Web services, in which case there 

is a WSDL file for each Web service.

Answer: B

2. Susan has been asked to make several modifications to the CustOrders composite application. Which of the 

following will Susan be able to do using the Composite Application Editor?

A.Add a page to the application.

Rename a page in the application.

Edit wires for components of the application.

B.Add a page to the application.

Add a PIM component view to the application.

Create a new component for the application.

C.Add a PIM component view to the application.

Add a new column to a PIM component view.

Delete a page from the application.

D.Delete a page from the application.

Create a new component for the application.

Edit wires for components of the application.

Answer: A

3. Annika needs to update the WSDL file that controls the wiring between components in her composite application. 

Where would she find that WSDL file in Domino Designer?

A.Composite Applications > Files

B.Composite Applications > Applications

C.Composite Applications > Web Services

D.Composite Applications > Wiring Properties

Answer: D
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4. Theodor created new Wiring properties for his composite application, CustOrder.nsf, using Domino Designer. He 

named the Wiring properties "CustOrder", and has just finished defining the Wiring properties using the Property 

Broker Editor. What should Theodor do next to store the updated Wiring properties in the design of CustOrder.nsf?

A.Close the Property Broker Editor window. As with other elements of a Domino database, the compiled code is 

automatically stored within the NSF.

B.Select File > Save, and select File > Exit from the Property Broker Editor. With the CustOrder Wiring properties 

still highlighted in Domino Designer, select File > Save.

C.Select File > Save, and select File > Exit from the Property Broker Editor. In the Wiring Properties work pane of 

Domino Designer, click the Refresh button, select ~CustOrder.wsdl and click Open.

D.Close the Property Broker Editor window. In the Wiring Properties work pane of Domino Designer, select 

~CustOrder and click Compile WSDL. The name updated Wiring properties are saved in the NSF and the name 

reverts to "CustOrder".

Answer: C

5. Charles has been asked to make modifications to the EmpTravel composite application. He knows the server and 

file path for the application. How can Charles open the composite application in Domino Designer?

A.Add the application to his Workspace as he would for any Domino application. With the application highlighted, 

select View > Design to open the application in Domino Designer.

B.Add the application to his Workspace as he would for any Domino application. With the application highlighted, 

select Edit > Edit Composite Application to open the application in Domino Designer.

C.A composite application cannot be opened in Domino Designer. Charles needs to open the application from his 

Workspace or Bookmarks, and then select Edit > Edit Application to open the application in the Composite 

Application Editor.

D.A composite application cannot be opened in Domino Designer. But Charles can select the application from his 

Workspace or Bookmarks, and then select Edit > Edit Application to open the application in the Composite 

Application Editor.

Answer: A

6. Louise is writing some LotusScript to put on an action button. She needs to access the NotesPropertyBroker 

object in the script. What Notes class is the NotesPropertyClass descended from?

A.NotesSession

B.NotesDocument

C.NotesUIWorkspace

D.NotesCompositeApp

Answer: A

7. Gary is writing his first composite application on the Domino platform. One task he needs to do is to define the 

properties of his application. What are properties?

A.Properties are the methods that are defined by the application components.

B.Properties are the data elements that exist between the application components.

C.Properties are the design elements that exist between the application components.

D.Properties are the Web services that are defined between the application components.

Answer: B

8. Jean has created an NSF component and needs to provide the communication between this component and an 

existing component. How can she begin this next step in the development of her composite application?

A.Open the composite application in the Notes client. Select Edit > Component Communications to launch the 

WSDL Editor.

B.Open the composite application in the Notes client. Select View > Wiring Properties to launch the Property Broker 

Editor.

C.Open the composite application in Domino Designer. Select Composite Applications > Component 

Communications to launch the WSDL Editor.

D.Open the composite application in Domino Designer. Select Composite Applications > Wiring Properties, and click 

 

 

 

 

 

 

 

 

 

 

 
  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

   

 

 
      

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 
   

 

 

 
 

 

 
   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

   

 

                                

                                

                



    

       

          

 

       

   

     

     

  

  

     

 

   

     

 

  

 

   

   
        

 

       

    

     

 

     

 
 

   

 

   
   

 

 

   

        

 

   
   

 

      

    

 

       

       

 

 

  

 

 

  

  

     

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

New Wiring Properties. Select the new Wiring Property and click Open File to launch the Property Broker Editor.

Answer: D

9. George is maintaining a Notes composite application in Designer. He wonders where the details for the actions and 

properties are stored. Where would George find this information?

A.In Designer under the Composite Application Editor

B.In Designer as a component of the Property Broker Editor

C.In Designer as a WSDL file under Shared Code > Composite Applications

D.In Designer as an XML file under Composite Applications > Applications

Answer: D

10. Marjory has added an NSF component to her composite application. The component surfaces the Customers view 

from the cust.nsf application. Marjory wants users to be able to select a CustomerName and then display orders for 
that customer using a different component. What is one step Marjory should take to begin enabling the inter-

component communication?

A.Using Domino Designer, open the Customers view. From the Advanced tab of the view properties, select Enable as 

component.

B.Using Domino Designer, open the Customers view. From the Advanced tab of the CustomerName column 

properties, select Enable as component.

C.Using the Property Broker Editor, create a property for CustomerName, and select Allow publishing to make 

CustomerName available to consuming components.

D.Using the Property Broker Editor, create a data type for CustomerName, and select Allow publishing to make 

CustomerName available to consuming components.

Answer: C

11. Eleanor has been asked to create a composite application, surfacing elements from several Notes applications. 

Which elements will she be able to incorporate into NSF components?

A.Documents, Folders, Forms, Framesets, Navigators, Pages, and Views can all be surfaced as components.

B.Folders, Forms, Framesets, Navigators, Pages, and Views can be surfaced as components.

Documents cannot.

C.Forms, Framesets, Pages, and Views can be surfaced as components.

Documents, Folders, and Navigators cannot.

D.Documents, Folders, Forms, and Views can be surfaced as components.

Framesets, Navigators, and Pages cannot.

Answer: A

12. Rusty is going to create a composite application using NSF design elements. What design elements can be used 

in a Notes composite application?

A.Pages, Forms, Views, Shared Actions, and Agents

B.Wiring Properties, Property Brokers, Shared Agents

C.Frames, Framesets, Pages, Forms, Views, Folders, and Navigators

D.Script Libraries, Web Services, Shared Actions, Data Connections, and Property Brokers

Answer: C

13. Eric has been assigned to a project where the underlying design uses service-oriented architecture (SOA)? What 

is SOA?

A.A system design where Domino only responds to SOAP calls to deliver data.
B.A method by which Domino-based applications can run on non-Domino servers. 

C.A system design where Domino invokes Web service agents to get all of its data.

D.An approach to system integration and architecture by using the services of other modules.

Answer: D

14. Pierre has been asked to create a composite application to allow users to interact with data from multiple 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 
   

 

 

 
 

 

 
   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

   

 

                                

                                

                



    

       

          

 

       

   

     

     

  

  

     

 

   

     

 

  

 

   

   
        

 

       

    

     

 

     

 
 

   

 

   
   

 

 

   

        

 

   
   

 

      

    

 

       

       

 

 

  

 

 

  

  

     

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

   

 

 
      

 

 

 

 

components. He will be using the Property Broker Editor as he develops his application. What is the purpose of the 

Property Broker?

A.The Property Broker allows components to interact through the use of a Property and Action registry and a wiring 

mechanism.

B.The Property Broker controls the allowed operations for each user or component interacting with the composite 

application, via the application ACL.

C.When a component method is invoked, the Property Broker compiles the method code (if needed) and then 

executes the code on behalf of the component.

D.The Property Broker places each component in its position within the user interface, based on properties defined 

with the Property Broker Editor, and stored in the generated WSDL.

Answer: A

15. Philip is enhancing the Sales composite application. Philip would like to add two new components to the 
application. He would like to add a link, indented under the existing Customers navigation link. The new link should be 

called "Research" and should open a pane that would surface the new components

How can Philip add this new link in the desired location in the left navigation?
A.Open the Sales application in the CAE. Right-click Customers and select Add Page > As Child. For the Page Title 

option, enter "Research".

B.Open the Sales application in Domino Designer. From the Composite Applications section, select New Page. For 

the Name option, enter "CustomersResearch".
C.Open the Sales application in Domino Designer. Expand the Composite Applications section, select Applications > 

Sales > Add Page. For the Page Title option, enter "CustomersResearch".

D.Open the Sales application in the CAE. Drag one of the desired components from the Component Palette onto a 
blank area of the navigation pane. Right-click the new entry and in the Component properties, change the Parent 

option from "Customers" to "CustomersResearch".

Answer: A

16. Alex is developing a composite application. He has created the basic user interface. Alex is now going to define 

the properties for his application. What is the role of properties in a composite application?

A.Properties are the data items that comprise the information flow.

B.Properties are the methods that transfer data between components.

C.Properties specify the layout of the elements of a composite application in the user interface.

D.Properties are used to designate the allowed operations for each user and component within the composite 

application.

Answer: A

17. Lucy has begun using the Time Reporting composite application. When she selects the name of a Project to 

which she is charging time, another area of the screen displays the HoursCharged that have been recorded for this 

Project previously. One of the components of the composite application provides the HoursCharged data. The 

composite application logic that consumes this data (the HoursCharged) is called what?

A.WSDL

B.Wiring

C.An Action

D.A Property

Answer: C

18. Judi is creating a Notes composite application. Her main view has a column called Nationality, and it is a property 

of her composite application. Where will she find the property attribute for that column?

A.In the Shared Code area, under WSDL files

B.In the Shared Resources area, under WSDL file

C.In the Composite Applications area, under Applications

D.In the View Column properties box, final tab under the Composite Settings area

Answer: D

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

    

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

      

   

 

                                

                                

                



    

       

          

 

       

   

     

     

  

  

     

 

   

     

 

  

 

   

   
        

 

       

    

     

 

     

 
 

   

 

   
   

 

 

   

        

 

   
   

 

      

    

 

       

       

 

 

  

 

 

  

  

     

   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

   

 

 
      

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 

 

 
   

 

 

 
 

 

 
   

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

19. Harold used the New Comp App button in Domino Designer to create a new, empty composite application 

definition in his Lotus Notes database. If he sets the database launch properties to Launch As Composite Application 

and points to the new definition, what will happen when he opens the database?

A.The Notes client will display an error message and the database will not open.

B.A screen will be displayed, prompting him to edit the new composite application.

C.The default frameset will be displayed because the composite application definition is empty.

D.The Composite Application Editor will open immediately, allowing him to edit the new composite application.

Answer: B

20. Bennett is reviewing a composite application on Domino and he sees a WSDL file in the design. What is 

contained in a WSDL file for a composite application?

A.Application code for actions and agents

B.Application definitions for the views and forms

C.Application definitions for security levels, methods, and agents

D.Application definitions for data types, properties, namespaces, and actions

Answer: D
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